Skip to main content

USB Ports with Gen2 12 Port and MacBook Pro M1



  • Maroš Barabas

    Hello, same issue. First, only front (where audio is located) worked, now no USB is working, audio output does not work as well. Sometime I need to change HDMI output port, because my monitor randomly go off/on like there is lost of signal for about 1s.

    Macbook Air M1, Big Sur 11.2.1, tested with Logitech camera USB 

  • Corrie Anderson

    I am having the same problems with my hard drives disconnecting if I move the HyperDrive at all while trying to plug something into one of its ports. Hard drives already plugged in disconnect so I have to retype their passwords to mount them again and my monitor periodically goes blank without warning. Have you folks found any solutions to your issues?

  • Lukas Domek

    Same here with my MacBook Air M1. I have random DisplayPort issues with an apple 27” Cinema Display (mini DP port).
    Moreover the external DisplayPort display stays black after boot.
    Since I updated on macOS 13.3.1 additional there are LAN issues. I need to reset the LAN service to get network connection.

    Seems to be a common issue, any suggestions?

  • Howard Dinin

    Using the 12-port with a MacBook Air M1, at first with no problems. Then random problems keeping various ports live (have used all ports except EtherNet and Displayport and earphone), with occasional problems having the hub lose power spontaneously altogether. Hardest is to keep HDMI display connected as a mirrored display. Connected to an ASUS 27" LCD Monitor (model PB278), which has worked without incident for three years with previous Intel-chip MacBook Pro models.
    At first thought there were cabling problems, but have swapped out various cables in all cases (HDMI, USB-C 3 to various USB connectors (including 3Gen1, USB-C 2, USB-A), and including Thunderbolt 3 to Thunderbolt 3). Sometimes switching cables provided a temporary fix. Final stable solution for now is to mirror displays and keep cover open on MacBook, and to keep power cable from 12-port to AC adapter (which is a Hyper-Juice GaN 100w) disconnected from the hub. As SMC cannot be rebooted, and configuring PRAM on the M1 machines for now is complicated, requiring settings changes in Terminal, I suspect there are some incompatibilities embedded for now in the firmware for this first generation chip which are not completely happy with the circuitry in the 12-port hub. Best I can offer is this anecdotal behavioral observation. (Am running Big Sur 11.4, and the Air is maxed out for SSD size and DRAM capacity).


Please sign in to leave a comment.